# deepset-ai/haystack · RepoSense Release & Migration Intelligence

> Haystack now requires `anyio&gt;=4.14.2`. `anyio` is insta. Upgrade immediately to patch advisory. Migration: Low.

## Metadata
- **Repository URL**: https://github.com/deepset-ai/haystack
- **Primary Package**: `haystack-ai` (NPM)
- **Categories**: `AI-FRAMEWORK`, `AI-AGENT`, `BACKEND`
- **Latest Version**: `v2.31.1`
- **Semantic Status**: `SECURITY_PATCH`
- **Bundle Size Impact (unavailable)**: `Size Unavailable`
- **Atom Ingestion Feed**: https://github.com/deepset-ai/haystack/releases.atom

## The Human Context (Plain-English Pitch)
haystack-ai is an open-source library and developer tool in the deepset-ai/haystack ecosystem. It saves developers from writing repetitive low-level boilerplate from scratch by providing a battle-tested, open-source implementation ready for production.

## Stage 1 Executive Summary ([Core Change] + [Required Action] + [Migration Effort])
Haystack now requires `anyio&gt;=4.14.2`. `anyio` is insta. Upgrade immediately to patch advisory. Migration: Low.

## Breaking Changes & Required Actions
- Haystack now requires `anyio&gt;=4.14.2`. `anyio` is installed transitively through `httpx` and `openai`; versions before 4.14.2 are affected by CVE-2026-63374 (GHSA-82r6-8w77-9...
- Haystack now requires `certifi&gt;=2026.10.19`. `certifi` is installed transitively through `httpx` and `posthog`; earlier versions trust eMudhra/emSign certificate authorities ...

## Migration Snippet
```ts
npm install haystack-ai@2.31.1
```

## Ecosystem Compatibility Matrix & Graph Warnings
- **TypeScript 5.x** [`COMPATIBLE`]: Ships standard TypeScript declaration files without type regressions.

## Zero-Noise Release Timeline
- **v2.31.1** (2026-11-03) [SECURITY_PATCH]: Haystack now requires `anyio&gt;=4.14.2`. `anyio` is insta. Upgrade immediately to patch advisory. Migration: Low.

## Upgrade & Migration Q&A (GEO Direct Answers)
### Is deepset-ai/haystack v2.31.1 safe to upgrade in production?
deepset-ai/haystack v2.31.1 is classified as SECURITY_PATCH (PATCH release). Haystack now requires `anyio&gt;=4.14.2`. `anyio` is insta. Upgrade immediately to patch advisory. Migration: Low.

### What breaking changes or compatibility risks exist in deepset-ai/haystack v2.31.1?
No breaking API changes or peer dependency conflicts are recorded for deepset-ai/haystack v2.31.1 in the RepoSense compatibility graph.

### What is the bundle size impact of haystack-ai v2.31.1?
Measured bundle size telemetry is currently unavailable for haystack-ai v2.31.1; verify build output locally before deploying.

### How do I upgrade haystack-ai to v2.31.1?
Upgrade haystack-ai to v2.31.1 by running "npm install haystack-ai@2.31.1" and applying the migration steps: npm install haystack-ai@2.31.1
